Problembehebung bei integrierten Displays

Aus ZusiWiki
Wechseln zu: Navigation, Suche

Was tun wenn die integrierten ZusiDisplays nicht so funktionieren wie erwartet?

Es werden gar keine Displays dargestellt

  • Ist ZusiDisplay grundsätzlich funktionsfähig? Dazu im Zusi-Programmverzeichnis den Unterordner _Tools\ZusiDisplay aufsuchen und dort die ZusiDisplay.exe starten. Wenn dann eine Fehlermeldung kommt, die zur Installation von .NET Core auffordert, dem Link folgen und die x86-Version von .NET Core installieren. Dies gilt auch, wenn man ein x64-System betreibt. Mit der x64-Version von .NET Core funktioniert ZusiDisplay nicht.
  • Ist eine Sicherheitssoftware installiert, die den Start externer Prozesse stillschweigend unterbindet? Dann muss diese Sicherheitsfunktion abgeschaltet werden, oder ZusiSim.exe auf eine Whitelist des Sicherheitsprogramms gesetzt werden.

Displays reagieren verzögert

  • In den Simulator-Einstellungen muss der Haken "Daten nur bei Änderungen schicken" gesetzt sein.
  • Das empfohlene Sende-Intervall in den Simulator-Einstellungen ist 0,3 Sekunden. Niedrigere Werte können höhere Last bei ZusiDisplay verursachen.
  • In den Einstellungen von ZusiDisplay gibt es einen Schieberegler für die Update-Rate der Führerstands-Integration. Auf schwächeren Rechnern kann man versuchen, diesen auf "seltener" zu setzen.

Unstete Bildfolge der Simulation

Falls in Führerständen mit integrierten Displays Mikroruckler auftreten, kann versuchsweise vSync abgeschaltet werden und mit der Framebremse experimentiert werden (ein Nutzer berichtete davon, dass auf seinem Bildschirm mit 60 Hz Bildwiederholrate die Mikroruckler weniger wurden, wenn die Framebremse auf 50 fps eingestellt war).